Degraded Call functionality for Apple devices

Major incident Call provider
2026-06-19 00:12 -11 · 48 minutes

Updates

Resolved

Update: The issue affecting our call service has been resolved.

The disruption was related to a certificate management issue, and functionality has now been fully restored.

June 19, 2026 · 00:54 -11
Issue

We are aware of an issue currently affecting our call service for users on iOS and are actively investigating. Our team is working to restore full service as quickly as possible. We apologize for the inconvenience and will provide further updates as soon as they are available.

June 19, 2026 · 00:12 -11

← Back